Jump to content
Virtual Regatta Club House

Have Account but Can't Log in to Play


Recommended Posts

  • 7 months later...

I have an account for the last 4+ years, 3000 credits and currently "sailing" in the Vendee Globe. Tried to check on things last night mow I only have an option to join the race. I have only had two email addresses and neither of the are now recognised. Tried to reset password but that doesn't work, cannot contact VR because you gave to be registered. Very frustrating anybody have ideas on what to try next. 

Link to post
Share on other sites
  • 4 weeks later...

I'm having the same problem. I created an account and got to the club house but I haven't been able to play the game with it. I get "wrong credentials" every time I try. I've done a password reset, and am still having the same issue both on my PC and my iPad.

Help!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...